MPG cluster provisioning is broken

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 06:39 UTC

Investigating

New MPG cluster provisioning is broken. Existing MPG clusters are not affected. Newly created organizations may see errors while SSHing into their machines. We are investigating the issue.
Posted Jun 15, 2026 - 06:20 UTC