Network instability in IAD region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 19:31 UTC

Monitoring

A mitigation is in place and IPv4 and IPv6 connectivity has returned to normal. We are continuing to monitor.
Posted Dec 04, 2025 - 18:57 UTC

Update

We are continuing to investigate this issue.
Posted Dec 04, 2025 - 17:52 UTC

Investigating

We are investigating alerts and reports of unstable networking (dropped packets, closed connections) in our IAD region. This impacts both user applications and Managed Postgres clusters as well as some API operations.
Posted Dec 04, 2025 - 17:47 UTC
This incident affected: Deployments and Regional Availability (IAD - Ashburn, Virginia (US)).