Increased API latency

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 13:26 UTC

Investigating

We are investigating some database issues causing high latency on some API endpoints and dashboard operations. You may experience intermittent "503 service unavailable" errors at this time.
Currently deployed apps continue to run.
Posted Jul 29, 2026 - 12:41 UTC
This incident affected: Dashboard, Machines API, and Deployments.