Metrics currently experiencing issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 28, 2026 - 21:20 UTC

Investigating

We are currently investigating an issue with our metrics cluster.
Posted Jun 28, 2026 - 08:10 UTC
This incident affected: Metrics.