Packet loss in North America

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 12:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2025 - 12:08 UTC

Identified

We are seeing high packet loss in North American regions. We are working with our upstream providers to re-route our traffic as soon as possible.
Posted Sep 24, 2025 - 09:45 UTC