Network issues in SIN

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 16:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2025 - 16:13 UTC

Identified

We have identified an upstream issue and are currently working to restore connectivity. In the mean time, we have temporarily rerouted Anycast traffic away from SIN.
Posted Dec 15, 2025 - 16:02 UTC

Investigating

We are investigating network issues in SIN. Apps might experience partial outage connecting to some IPs.
Posted Dec 15, 2025 - 15:49 UTC
This incident affected: Regional Availability (SIN - Singapore).