Machines API issues in SEA, SJC and GRU

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:58 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted Oct 20, 2025 - 20:41 UTC

Investigating

We are investigating an issue with machines API in particular regions. Machine updates and requests to machines located in these regions may fail.
Posted Oct 20, 2025 - 20:27 UTC
This incident affected: Machines API and Regional Availability (GRU - Sao Paulo, Brazil, SEA - Seattle, Washington (US), SJC - San Jose, California (US)).