Elevated deployment errors

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 30, 2026 - 04:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2026 - 03:37 UTC

Identified

We identified the issue and are working on a fix.
Posted May 30, 2026 - 03:13 UTC

Investigating

We're investigating an increase in deployment errors affecting some users. At this time, creating or updating Machines may erroneously fail with the message: "We require your billing information, please add it at https://fly.io/dashboard//billing".
Posted May 30, 2026 - 02:42 UTC
This incident affected: Deployments.