Fly Metrics - Grafana Log Maintenance

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 03:00 UTC

Monitoring

Cluster maintenance has completed and log search performance is returning to normal. We are continuing to monitor the cluster to ensure consistent performance.
Posted Nov 07, 2025 - 01:58 UTC

Identified

We are currently performing maintenance on the log cluster that powers log search in fly-metrics.net. Users may see slow queries or queries timing out during this period.

Viewing live logs via the `flyctl logs` command and from the log tab of the fly.io dashboard continue to work as normal, as does shipping logs using the Fly Log Shipper.
Posted Nov 06, 2025 - 21:40 UTC
This incident affected: Metrics.