Intermittent API and Web UI errors

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jan 19, 2021 - 21:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 19, 2021 - 20:52 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jan 19, 2021 - 20:37 UTC

Identified

We host our customer facing API on a popular cloud hosting provider's infrastructure to minimize outages. That provider is currently having an outage, causing the API to serve errors to flyctl and the Fly web dashboard.
Posted Jan 19, 2021 - 20:36 UTC
This incident affected: Dashboard, Machines API, Deployments, Remote Builds, and Logs.