Depot builder failures

Incident Report for Fly.io

Monitoring

A fix has been implemented and we are monitoring builds. Standard flyctl builds should be working again for customers in all regions.
Posted Sep 15, 2026 - 04:51 UTC

Identified

We have identified an issue with deploying via Depot for users connecting through our SYD and JNB regions. Affected customers in these regions can deploy successfully using the --depot=false or --buildkit arguments to flyctl.
Posted Sep 15, 2026 - 04:45 UTC

Investigating

We are investigating reports of Depot builds failing for some customers. Affected customers can deploy successfully using the --depot=false or --buildkit arguments to flyctl.
Posted Sep 15, 2026 - 04:08 UTC
This incident affects: Deployments.