Degraded Managed Postgres Control Plane in ORD

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 14, 2026 - 14:27 UTC

Monitoring

A fix has been implemented and we are seeing full recovery of the control plane in ORD. With that recovery we are seeing impacted replicas catching up and clusters returning to normal health. We're continuing to monitor for full recovery.
Posted Feb 14, 2026 - 14:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 14, 2026 - 13:47 UTC

Identified

The issue has been identified and we are working on a fix. The majority of MPG clusters in ORD continue to run normally, though some users may still see degraded replicas at this time. Some clusters in the region will have experienced a primary -> replica failover.
Posted Feb 14, 2026 - 11:47 UTC

Investigating

We are currently investigating issues with the MPG control plane in ORD. A small number of clusters in the region may be seeing replication lag or PGBouncers connectivity issues at this time.
Posted Feb 14, 2026 - 11:33 UTC
This incident affected: Managed Postgres (Management Plane - ORD).