Cost Explorer fails to load

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 12:10 UTC

Investigating

We are currently investigating this issue.
The page currently displays: "We’re having trouble loading the cost breakdown."
Posted Mar 03, 2026 - 10:50 UTC
This incident affected: Dashboard.