Upstash Redis Outage

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 11, 2026 - 18:41 UTC

Monitoring

A fix has been implemented and we are seeing Upstash Redis connectivity return to normal across all regions. We continuing to monitor to ensure stable recovery.
Posted May 11, 2026 - 18:26 UTC

Update

We are continuing to work with Upstash on this issue. We have received reports of partial recovery for some users, however we are still seeing higher levels of degraded or failing connections connecting to Upstash Redis databases at this time.
Posted May 11, 2026 - 17:31 UTC

Update

We are continuing to work with Upstash on this issue.
Posted May 11, 2026 - 15:04 UTC

Investigating

We are working with Upstash to investigate issues with their Fly hosted Redis service. Users may see degraded or failing connections connecting to their Upstash Redis databases at this time.
Posted May 11, 2026 - 14:36 UTC
This incident affected: Extensions (Upstash for Redis).