Errors when adding or editing Github integrations for deployments

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 16:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 15:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 23, 2026 - 15:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 23, 2026 - 15:22 UTC

Investigating

We're investigating reports of "500" errors when trying to add a new Github integration or edit an existing Github integration in Fly.io/dashboard. This only affects "Launch an app from Github" or trying to change settings for an app set up this way. Existing integrations continue to work normally. It does not affect deploys done with `flyctl` or existing, running apps.
Posted Apr 23, 2026 - 15:05 UTC
This incident affected: Dashboard.