Certificate issuance delays

Incident Report for Fly.io

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2026 - 20:36 UTC

Update

We have the size of TLS certificate issuance backlog under control, but are still seeing some remaining issues and are currently working to clean up the edge cases.
Posted Aug 04, 2026 - 18:26 UTC

Identified

We believe we have identified the issue and are releasing a fix.
Posted Aug 04, 2026 - 17:02 UTC

Investigating

We're currently investigating issues related to certificate issuance. Certificates may be delayed for new custom domains.
Posted Aug 04, 2026 - 14:53 UTC
This incident affects: SSL/TLS Certificate Provisioning.