We are continuing to monitor for any further issues.
Posted May 28, 2026 - 22:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2026 - 22:33 UTC
Identified
We're still seeing connection issues originating from SJC/LAX/West Coast US and are still investigating.
Posted May 28, 2026 - 22:25 UTC
Monitoring
We have implemented a mitigation for the issue and are monitoring for stability. This issue happened on the edge hosts in SJC, which means that any traffic near/around SJC would have been affected during the incident. We will provide a more detailed write-up on our Infra Log (https://fly.io/infra-log/) later once we have a better picture of the entire incident.
Posted May 28, 2026 - 21:56 UTC
Investigating
We are currently investigating increased latency in SJC.
Posted May 28, 2026 - 21:08 UTC
This incident affected: Regional Availability (LAX - Los Angeles, California (US), SJC - San Jose, California (US)).