Leader Election Issues with PG Flex Clusters close to NA region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 17:10 UTC

Monitoring

A fix has been implemented and we are monitoring
Posted Mar 06, 2025 - 16:10 UTC

Investigating

We are investigating an issue where postgres flex clusters are unable to elect a new leader.
Posted Mar 06, 2025 - 16:08 UTC
This incident affected: Postgres Flex Clusters.