Degraded connectivity to Fly Registry

Incident Report for Fly.io

Resolved

We have identified that transoceanic subsea cable faults resulted in degraded connectivity to some registry instances in AMS, FRA, WAW regions. Our monitoring indicates error rates have improved after cordoning the affected instances at 16:40 UTC.
Posted 18 days ago. Mar 18, 2025 - 19:21 UTC

Monitoring

We are continuing to monitor results after cordoning affected registry instances.
Posted 18 days ago. Mar 18, 2025 - 17:23 UTC

Investigating

We are investigating timeouts connecting to instances of registry.fly.io in AMS, FRA, WAW regions. Customers may experience slower image pushes and pulls within Fly Machines in the affected regions.
Posted 18 days ago. Mar 18, 2025 - 17:06 UTC

Monitoring

We have cordoned the affected registry instances in AMS, FRA, WAW and are seeing timeout errors decrease.
Posted 18 days ago. Mar 18, 2025 - 16:40 UTC

Update

We are continuing to investigate the cause of increased connection timeouts to instances of our primary registry in AMS, FRA, WAW. Affected customers may be able to work around by pushing images to an alternate registry, registry2.fly.io:

FLY_REGISTRY_HOST=registry2.fly.io fly deploy
Posted 18 days ago. Mar 18, 2025 - 16:39 UTC

Investigating

We are investigating timeouts connecting to registry.fly.io. Customers may experience slower image pushes and pulls within Fly Machines.
Posted 18 days ago. Mar 18, 2025 - 15:52 UTC