Connection Issues in SJC

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 14:18 UTC

Monitoring

Between 13:55 and 14:03 UTC machines and MPG clusters hosted in the SJC region saw elevated connection errors. Users may have seen errors connecting to or from most machines in the region, as well as with deployments or updates to machines in the region.

Networking has returned to normal in the region, and we are continuing to monitor closely to ensure stable recovery.
Posted Mar 18, 2026 - 14:07 UTC
This incident affected: Managed Postgres (Management Plane - SJC) and Regional Availability (SJC - San Jose, California (US)).