Elevated latency and packetloss in North American regions

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 03:43 UTC

Monitoring

Network performance issues between North American regions have resolved and we're continuing to monitor.
Posted Feb 03, 2026 - 03:26 UTC

Investigating

We are currently investigating intermittent spikes of increased latency and packet loss between North American regions over the past hour. Users may see degraded network performance on traffic in and out of the IAD and SJC regions at this time.

We are working with our upstream networking providers to investigate and mitigate these issues.
Posted Feb 03, 2026 - 02:56 UTC
This incident affected: Regional Availability (IAD - Ashburn, Virginia (US), SJC - San Jose, California (US)).