IPv6 Networking Issues on some SJC hosts

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 15:57 UTC

Monitoring

We've deployed a fix on the impacted hosts and are seeing connectivity returning to normal. We are continuing to monitor to ensure full recovery.
Posted Aug 01, 2025 - 15:02 UTC

Investigating

We're investigating IPv6 connectivity issues on a small number of hosts in the SJC region. Machines on impacted hosts may see inbound/outbound connectivity issues over IPv6. IPv4 connections for these hosts are not impacted.

The majority of hosts in SJC continue to see normal IPv6 performance. Users seeing issues can re-create impacted machines in SJC or nearby regions by following the steps outlined here: https://fly.io/docs/apps/trouble-host-unavailable/
Posted Aug 01, 2025 - 14:41 UTC
This incident affected: Regional Availability (SJC - San Jose, California (US)).