Network instability in IAD region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 22:55 UTC

Update

A mitigation has been implemented restoring normal network connectivity. We are still working with our upstream providers to address the root cause.
Posted Dec 04, 2025 - 21:52 UTC

Investigating

We are observing IPv4 and IPv6 network instability in IAD affecting user Apps, as well as Managed Postgres clusters and some API operations. We are working with our upstream network infrastructure providers to resolve the issue.
Posted Dec 04, 2025 - 21:14 UTC
This incident affected: Managed Postgres (Management Plane - IAD), Deployments, and Regional Availability (IAD - Ashburn, Virginia (US)).