Deployment monitoring and app status have stale data
Incident Report for Fly.io
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 08:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 14, 2023 - 08:03 UTC
Update
Things are better but deploys / release commands are still slower than they should be. Instance statuses are also delayed a bit as our state is synchronizing.
Posted Mar 13, 2023 - 15:25 UTC
Monitoring
We've upped the memory allocated for that app so it doesn't crash anymore and it seems a lot more stable now.
Posted Mar 13, 2023 - 14:32 UTC
Investigating
A synchronization service we are running crashing from time to time causing deployment monitoring to fail at times and app status to show erroneous information about instances.

The cause of the crash has not yet been determined.
Posted Mar 13, 2023 - 13:15 UTC
This incident affected: Platform and Tools (Deployments).