Elevated API issues

Incident Report for Fly.io

Resolved

All systems are now operating normally. We’ll continue to monitor closely, but no further impact is expected.
Posted Jul 17, 2025 - 14:29 UTC

Monitoring

The reseeding process is complete and API responses are back to normal. We continue to monitor the system to ensure everything remains healthy.
Posted Jul 17, 2025 - 12:28 UTC

Identified

We're making progress with reseeding our state store and are now working on speeding up the reseed process overall. Users may continue to see inconsistencies with our API.
Posted Jul 17, 2025 - 01:42 UTC

Update

We're continuing to investigate this issue.
Posted Jul 17, 2025 - 00:40 UTC

Update

We've started a rollout to our global state store and are noticing degraded performance for our API. Users may see inconsistent data related to their machines.
Posted Jul 17, 2025 - 00:09 UTC

Investigating

We're seeing a higher number of 500s when calling the Machines API or when trying to launch a machine.
Posted Jul 17, 2025 - 00:02 UTC
This incident affected: Machines API and Deployments.