Increased app-not-found errors

Incident Report for Fly.io

Identified

We have identified the issue as failed insertions in a subset of Corrosion batches. These failures trigger retries, which can cause timeouts for other batches.
Posted Aug 09, 2026 - 03:50 UTC

Investigating

We are currently investigating app-not-found errors returned by Machines API calls made shortly after creating new applications.
Posted Aug 09, 2026 - 02:50 UTC
This incident affects: Machines API.