Elevated GraphQL API issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 23:59 UTC

Monitoring

The issue has now been mitigated, and all services are restored and working normally. We're continuing to investigate the underlying issue further.
Posted Jun 23, 2025 - 20:21 UTC

Identified

We've identified the issue and implemented a fix, and are seeing services gradually recover. We're continuing to investigate the underlying issue further.
Posted Jun 23, 2025 - 19:47 UTC

Investigating

We're seeing a higher number of 500s when calling the Machines API, running a deploy, or attempting to access the dashboard. We're currently investigating the issue.
Posted Jun 23, 2025 - 19:12 UTC
This incident affected: Dashboard, Machines API, and Deployments.