State database issues in GRU

Incident Report for Fly.io

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2026 - 17:27 UTC

Identified

We have identified a bug and are working on a fix.
Posted Sep 24, 2026 - 16:58 UTC

Investigating

We are investigating issues in GRU related to a migration of our distributed state database. Apps continue to run, but creating or updating machines in GRU region may fail. Connections to apps in GRU, or connections from clients near GRU region, may fail at this time
Posted Sep 24, 2026 - 16:31 UTC
This incident affects: Regional Availability (GRU - Sao Paulo, Brazil).