Network Issues in SIN

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 04:55 UTC

Monitoring

Network connectivity in SIN has been fully restored. We're continuing to monitor.
Posted Jun 17, 2026 - 04:38 UTC

Update

We are seeing recovery of network connectivity between SIN and most destinations. We're continuing to work with our upstream provider to resolve the remaining issues.
Posted Jun 17, 2026 - 04:22 UTC

Identified

Some machines in SIN are unreachable. A few Managed Postgres clusters may fail to fail-over or update. We are in the process of fixing this with our upstream provider.
Posted Jun 17, 2026 - 03:47 UTC

Investigating

We are currently investigating network connectivity issues in the SIN region. Hosted apps may be unavailable.
Posted Jun 17, 2026 - 03:21 UTC
This incident affected: Regional Availability (SIN - Singapore).