Deploys using Depot Builders failing

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 21:21 UTC

Monitoring

A fix has been implemented by Depot (https://status.depot.dev/incidents/01K8NTPVB41CD7NT3059QQ5MD8), and we are seeing recovery. We are continuing to monitor.
Posted Oct 28, 2025 - 21:06 UTC

Identified

We are seeing intermittent deploy failures when using Depot builders. Customers can also follow the Depot status page at https://status.depot.dev for updates.

Customers can still deploy using Fly.io hosted builders with `fly deploy --depot=false`
Posted Oct 28, 2025 - 20:37 UTC

Monitoring

We are seeing deploys using Depot builders succeed again, but we are continuing to monitor.

Customers can still deploy using Fly.io hosted builders with `fly deploy --depot=false`
Posted Oct 28, 2025 - 19:05 UTC

Investigating

We are investigating failures when trying to build using the default Depot builders.

The recommended workaround is to use `--depot=false` with `fly deploy`.

The error is`Error: failed to fetch an image or build from source: error building: unavailable: unexpected EOF`
Posted Oct 28, 2025 - 18:46 UTC
This incident affected: Remote Builds.