Secrets service outage

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 20:33 UTC

Monitoring

We have failed over the secrets database to a replica, and the Machines API appears healthy now. We are monitoring for any further issues.
Posted Aug 14, 2026 - 20:08 UTC

Identified

We are working to recover our secrets service after a failed deployment. Apps continue to run, but it is not possible to create new apps or update secrets at this time.
Posted Aug 14, 2026 - 19:30 UTC
This incident affected: Machines API.