Fly.io Dashboard and GraphQL issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 03:06 UTC

Monitoring

The database has recovered from its load spike and error rates have returned to normal levels.
Posted Jul 02, 2025 - 02:43 UTC

Investigating

We're investigating elevated database load causing timeouts and elevated 500 error rates on the Fly.io Dashboard and the GraphQL API.
Posted Jul 02, 2025 - 02:15 UTC
This incident affected: Dashboard and Deployments.