API errors when creating machines
Incident Report for Fly.io
Resolved
This incident is resolved.
Posted Feb 22, 2024 - 22:32 UTC
Monitoring
We've deployed a fix for this problem and are monitoring to ensure everything is working normally.
Posted Feb 22, 2024 - 22:08 UTC
Identified
We've identified the cause of this issue. We've determined it's most likely to affect deploys of newly-created organizations and/or applications. It might affect deploys even on old applications with builder failures. A mitigation for the latter is to use --local-only when deploying. Full resolution is underway.
Posted Feb 22, 2024 - 21:41 UTC
Investigating
Machine creation operations, including deploys, currently fail with "could not launch machine: failed to launch VM: failed to get org". Other operations such as destroy work normally. Currently-running machines continue to work normally.
Posted Feb 22, 2024 - 21:18 UTC
This incident affected: Platform and Tools (API, Deployments).