Registry pulls using a local docker client return an error

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 16:42 UTC

Update

Newly pushed images should not hit this. We are monitoring errors actively.
Posted Oct 08, 2025 - 12:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 12:25 UTC

Investigating

Registry pulls locally using a docker client return a "manifest not found" error. This shouldn't affect `fly deploy`. We are investigating this issue.
Posted Oct 08, 2025 - 11:52 UTC