Delayed Metrics

Incident Report for Fly.io

Update

Metric ingestion is still delayed for some customers. We’re seeing gradual improvement and continue to monitor the situation while the system catches up.
Posted Jun 29, 2026 - 15:56 UTC

Update

We are still in the process of increasing the metrics cluster throughput to catch up with metric backlog.
Posted Jun 29, 2026 - 08:43 UTC

Update

We are continuing to see delayed metrics due to resource contention on a subset of metrics ingestion hosts, and we are working to rebalance ingestion traffic and reduce the backlog.
Posted Jun 29, 2026 - 05:34 UTC

Update

We are continuing to see delayed metric exports from a number of hosts. Users will see delayed or missing metrics for machines on impacted hosts at this time.
Posted Jun 29, 2026 - 02:58 UTC

Identified

We've identified an issue on multiple hosts causing delayed metric ingestion into our hosted fly-metrics.net dashboards. We are working on a fix.
Posted Jun 29, 2026 - 01:46 UTC

Investigating

We are investigating issues with customer facing metrics in the fly-metrics.net dashboard. Users may see delayed or missing metrics at this time.
Posted Jun 29, 2026 - 01:03 UTC
This incident affects: Metrics.