Networking issues in SJC

Incident Report for Fly.io

Resolved

This incident has been resolved. Networking in SJC has remained stable over the past two hours.

This was caused by a dark fiber maintenance, which had a larger-than-anticipated impact.
As a result, some transport capacity was lost, leading to packet loss to and from our servers.
Posted Jul 15, 2025 - 12:47 UTC

Update

We are continuing to investigate this issue.
Posted Jul 15, 2025 - 08:23 UTC

Investigating

We are currently investigating networking issues in SJC. Customers may see higher latency and elevated packet loss connecting to machines in this region.
Posted Jul 15, 2025 - 08:01 UTC
This incident affected: Customer Applications and Regional Availability (SJC - San Jose, California (US)).