Low capacity in IAD

Incident Report for Fly.io

Identified

We've brought some additional capacity online in IAD and are seeing improvements, and we're continuing to work on adding more and freeing up additional room.
Posted Mar 27, 2026 - 19:21 UTC

Update

We're continuing to evaluate our options for increasing short-term capacity in the IAD region.
Posted Mar 27, 2026 - 18:47 UTC

Investigating

We're currently investigating capacity issues in IAD that is preventing machine starts (machine creates are currently unaffected). This may result in deploys failing to complete (even for apps outside of the IAD region). As a workaround, using legacy Fly builders explicitly located in another region (i.e., `FLY_REMOTE_BUILDER_REGION=lhr fly deploy --depot=false --recreate-builder`) may help in the meantime.
Posted Mar 27, 2026 - 18:08 UTC
This incident affects: Deployments and Regional Availability (IAD - Ashburn, Virginia (US)).