Elevated GraphQL API errors

Incident Report for Fly.io

Resolved

This incident was caused by a failed Redis node that powers our GraphQL API. We were able to recreate the Redis node and restore service.

We are still investigating the root cause of the failure. In the mean time, all API endpoints now appear to be stable and errors have dropped to baseline level.
Posted Mar 03, 2026 - 21:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 20:36 UTC

Investigating

We're investigating elevated GraphQL errors that affect some API endpoints.
Posted Mar 03, 2026 - 20:18 UTC
This incident affected: Dashboard and Deployments.