flyctl deploy timeouts

Incident Report for Fly.io

Resolved

Earlier today, an issue caused elevated rate limiting and some deployment timeouts. A fix is in place and deployments are back to normal.
Posted Feb 17, 2026 - 14:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2026 - 13:42 UTC

Identified

We’re investigating elevated 429 errors from flaps causing deployment timeouts. Affected deploys are failing with:
✖ Failed: error waiting for release_command machine XX to finish running: timeout reached waiting for machine's state to change
Your machine never reached the state "destroyed".
Posted Feb 17, 2026 - 13:06 UTC
This incident affected: Deployments.