Elevated 502 Errors
Incident Report for Fly.io
Resolved
This incident has been resolved.

Some of our edges received incorrect state data for a small number of apps that used the bluegreen deploy strategy. This resulted in 502 errors when attempting to reach those apps. We identified approximately 36 apps that were impacted, including the Fly.io homepage and dashboard.
Posted Jun 27, 2024 - 21:22 UTC
Update
A small number of customer apps may still be seeing 502 errors due to stale state information. We are working to address this. For any apps still experiencing the error, re-deploying with `fly deploy` will correct the state information and resolve the errors.
Posted Jun 27, 2024 - 19:50 UTC
Monitoring
A full fix has been implemented and we continue to monitor platform status. Impacted customer apps should be operational shortly, if they are not already.
Posted Jun 27, 2024 - 18:06 UTC
Update
A fix has been deployed and The Fly.io homepage, dashboard, API and metrics pages are back online and operational. A small number of customer apps may still be seeing elevated 502 errors. We are working to address this currently.
Posted Jun 27, 2024 - 17:46 UTC
Identified
We have identified the cause of the issue and are working on a fix.
Posted Jun 27, 2024 - 17:41 UTC
Investigating
We are currently investigating elevated rates of 502 errors when accessing applications hosted on Fly.io, including the Fly.io homepage, dashboard, and fly-metrics pages.
Posted Jun 27, 2024 - 17:09 UTC
This incident affected: Platform and Tools (API, Dashboard, UDP Anycast, Corrosion) and Metrics.