Customer workloads are now starting and we're monitoring the affected hosts. Affected Managed Postgres instances will be investigated.
Posted Jul 03, 2026 - 04:41 UTC
Update
Power restoration is ongoing and we're making sure the hosts are healthy before starting customer workloads to avoid issues. Customer impact remains and updates to come.
Posted Jul 03, 2026 - 04:21 UTC
Update
Power restoration work in a subset of ORD is still in progress and impact remains ongoing for a subset of hosts and some Managed Postgres clusters.
Posted Jul 03, 2026 - 02:59 UTC
Update
Our provider has advised us their facilities team is working on restoring the power, we'll provide another update as soon as we learn more.
Posted Jul 03, 2026 - 00:54 UTC
Identified
We've identified and reported power issues with one of our upstream providers in ORD. We're waiting for an update from our upstream for a resolution. Some Managed Postgres clusters in ORD will be unavailable due to placement.
Posted Jul 03, 2026 - 00:29 UTC
Investigating
We are investigating an issue with one of our upstream providers in ORD. Machines across a subset of hosts may be unreachable or not running correctly. Deploys with machines on these hosts may fail at this time. Some Managed Postgres clusters in ORD region may be unavailable at this time.
Posted Jul 03, 2026 - 00:11 UTC
This incident affects: Managed Postgres (Management Plane - ORD) and Regional Availability (ORD - Chicago, Illinois (US)).