WireGuard gateway issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 18:43 UTC

Update

Our testing and monitoring indicates gateways should be back to normal; if you are still having problem using `flyctl ssh console`, try restarting the `flyctl` agent by `flyctl agent restart`.
Posted Aug 26, 2026 - 18:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2026 - 18:27 UTC

Investigating

We are investigating issues with our WireGuard gateways. Some CLI commands like `flyctl ssh console` or `flyctl proxy` may not work at this time. Apps continue to run.
Posted Aug 26, 2026 - 18:14 UTC