Deploys defaulting to Fly-hosted Builders

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 15:38 UTC

Monitoring

We are seeing improvements in Depot builder provision times and are switching the default deploy strategy back to them. We will continue to monitor builder performance closely.

Users with a preference can trigger a Fly builder based deploy with `fly deploy --depot=false` or use `fly deploy --depot=true` to force a depot-based deployment.
Posted Jun 25, 2026 - 15:08 UTC

Investigating

We are investigating delays provisioning Depot backed builders for deploys. We have switched the default `fly deploy` strategy to use fly hosted builders at this time.

Users can still trigger a depot based deploy with `fly deploy --depot=true`
Posted Jun 25, 2026 - 13:41 UTC
This incident affected: Deployments.