Delays issuing certificates

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jan 21, 2026 - 05:24 UTC

Monitoring

We have identified the congestion and released a fix, we'll continue to monitor while the jobs catch up.
Posted Jan 21, 2026 - 04:59 UTC

Investigating

We are currently investigating possible delays issuing ACME certificates for new hostnames.
Posted Jan 21, 2026 - 03:21 UTC
This incident affected: SSL/TLS Certificate Provisioning.