Network issues impacting EU <-> US traffic

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jan 01, 2026 - 05:52 UTC

Monitoring

We're seeing performance on impacted routes return to normal levels. Prior to recovering, we observed intermittent high packet loss for US EU traffic, most acutely from approximately Dec 31 23:35 to 23:45 UTC, and later from Jan 1 00:40 to 01:35.
Posted Jan 01, 2026 - 02:01 UTC

Investigating

We've detected degraded network performance on some of our upstream network providers, impacting traffic between US and EU regions. We're in contact with these teams as we monitor for recovery.
Posted Jan 01, 2026 - 01:09 UTC