Machines failing to start in DFW

Incident Report for Fly.io

Resolved

This incident has been resolved. Machine creates in DFW continue to work normally.
Posted Mar 18, 2026 - 18:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 12:40 UTC

Identified

The team is currently rolling out additional capacity in DFW which should help ease Machine start failures across the region.
Posted Mar 18, 2026 - 11:44 UTC

Investigating

We are investigating reports of machines failing to start in the DFW (Dallas) region with "insufficient memory" errors. This may cause deployment failures for applications running in DFW.

Our team is actively working to restore full capacity in the region. If you are affected, deploying to an alternate region may serve as a temporary workaround.

We will provide updates as the situation progresses.
Posted Mar 18, 2026 - 09:58 UTC