Log Search Performance issues on Fly-Metrics.net

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 06:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 06:05 UTC

Identified

The issue has been identified and a fix is being implemented. You may see elevated search latency for your app logs.
Posted Nov 06, 2025 - 05:53 UTC

Update

We are continuing to investigate this issue.
Posted Nov 06, 2025 - 05:06 UTC

Update

We are continuing to investigate this issue.

Viewing logs via the Fly.io Dashboard live log viewer, `flyctl logs`, and the fly-log-shipper remain unimpacted by this.
Posted Nov 06, 2025 - 01:46 UTC

Investigating

We are currently investigating issues with the log search in the fly-metrics.net grafana dashboard. Users may see log queries take longer than usual, or fail with a timeout error. Retries generally succeed.

Viewing logs via the fly.io/dashboard log viewer, `flyctl logs`, and the fly-log-shipper are not impacted by this.
Posted Nov 06, 2025 - 00:01 UTC
This incident affected: Metrics.