Logs issues in IAD

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 19, 2026 - 20:56 UTC

Investigating

We are investigating an issue with logs and metrics in IAD region. New logs and metrics from machines in IAD region may be missing, but past logs/metrics are still accessible. Apps continue to run.
Posted May 19, 2026 - 19:16 UTC
This incident affected: Logs and Metrics.