Backend errors when trying to use Grafana to view logs

Incident Report for Fly.io

Resolved

This incident is resolved, Grafana logs are now working properly.
Posted Mar 23, 2026 - 16:27 UTC

Monitoring

We've deployed a fix and are monitoring the results. Logs are now be visible on Grafana.
Posted Mar 23, 2026 - 15:55 UTC

Identified

Using the Logs panel in Grafana at https://fly-metrics.net/ will show a 502 error from the backend and won't show any logs. You can use `fly logs` or the live log viewer directly on https://fly.io/dashboard to view streaming logs for the time being.
Posted Mar 23, 2026 - 15:41 UTC

Investigating

Using the Logs panel in Grafana at https://fly-metrics.net/ will show a 502 error from the backend and won't show any logs. You can use `fly logs` or the live log viewer directly on https://fly.io/dashboard to view streaming logs for the time being.
Posted Mar 23, 2026 - 15:18 UTC
This incident affected: Logs.