Degraded MPG clusters in IAD

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 20:44 UTC

Monitoring

We've rolled out a fix for the remaining impacted clusters, and we're now monitoring the results.
Posted Feb 10, 2026 - 20:00 UTC

Update

We've rolled out a fix for some additional impacted clusters, and we're continuing to work on the remaining clusters.
Posted Feb 10, 2026 - 19:53 UTC

Identified

We've identified the issue - some MPG clusters in IAD should be seeing improvements, and we're working on rolling out a fix for the remaining impacted clusters.
Posted Feb 10, 2026 - 19:15 UTC

Investigating

We're currently looking into an issue with MPG clusters in the IAD region.
Posted Feb 10, 2026 - 19:00 UTC
This incident affected: Managed Postgres (Management Plane - IAD).